В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Adamant0813
Adamant0813
01.12.2022 01:35 •  Информатика

Написать программу на языке паскаль. если можно, объясните , что за переменные там используются дана матрица а[8,8] четных чисел натурального ряда (от 2 до 64). 1)заполнить и записать матрицу. 2)определит число элементов меньших 18 и больших 60,заменить их на 0,затем записать получившуюся матрицу. 3)определить произведение главной диагонали и вывести эти элементы на экран. 4)реализовать определение суммы элементов любого столбца.

Ответ:
Var
a:array[1..8,1..8] of integer;{матрица}
i,i1,b,sum,st:integer;{первые 2 переменные для циклов,b - для заполнения матрицы, sum - для нахождения суммы чисел}
begin
  for i:=1 to 8 do begin
    for i1:=1 to 8 do begin
      b:=b+1;
      if b mod 2 = 0 then a[i,i1]:=b else a[i,i1]:=b+1;
      if a[i,i1] > 60 then write(0:3) else if a[i,i1] < 18 then write(0:3) else write(a[i,i1]:3);
     
    end;
    writeln;
  end;
  writeln('Главная диагональ');
  sum:=1;
  for i:=1 to 8 do begin
    sum:=sum*a[i,i];
    writeln(a[i,i]:i*2);
  end;
  writeln('Сумма - ',sum);
  write('Введите номер столбца - ');
  readln(st);
  sum:=0;
  for i:=1 to 8 do sum:=sum+a[i,st];
  writeln('Сумма чисел этого столбца - ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?