В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
PutinVodka
PutinVodka
15.06.2022 23:11 •  Информатика

Написать программы на языке python 1. введите с клавиатуры 5 положительных целых чисел. вычислите сумму тех из них, которые делятся на 4 и при этом заканчивается на 6. программа должна вывести одно число: сумму чисел, кратных 4 и оканчивающихся на 6 2.напишите программу для решения следующей . камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. необходимо определить максимальную зарегистрированную скорость автомобиля. если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведите «yes», иначе выведите «n0».программа получает на вход число проехавших автомобилей n (1 < n < 30), затем указываются их скорости. значение скорости не может быть меньше 1 и больше 300.программа должна сначала вывести максимальную скорость, затем yes или no.

Ответ:
CH4PP1E
CH4PP1E
26.05.2020 15:49

А самому, не?

1. def func():

i, summ = 0,0

while i < 5:

 i += 1

 x = int(input())

 if (x % 4 == 0) and (x % 10 == 6):

  summ += x

print(summ)

  func()

2.def speed():

n = int(input())

i = 0

maxSpeed = 0

text = 'NO'

while i < n:

 i += 1

 x = int(input())

 if x < 30:

  text = 'YES'

 elif x > maxSpeed:

  maxSpeed = x

print(maxSpeed, text)

 speed()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?