В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
PavlPavl
PavlPavl
11.03.2022 05:36 •  Информатика

Информатика составить программу в паскале и напишите , что обозначает переменные и m: =26*round(a*100/67); вот эту строку в частности в течение месяца бригада каждый следующий день работы выпускает на три изделия больше предыдущего. в первый день выпущено 42 изделия, что составило 67% дневной нормы. выполнит ли бригада месячную норму? (считать в месяце 26 рабочих дней)

Ответ:
irina197505
irina197505
26.05.2020 15:39

Program zadacha;

var a1,a26, norm1,norm26,S, d: real;  

n:integer;

begin

a1:=42;

d:=3;

n:=26;

norm1:=round(a1*100/67);//найдем дневную норму и округлим ее

a26:= a1+d*(n-1);//бригада выполнит в 26-й день, 26-й член арифметической прогрессии, где разность=3

norm26:= norm1*n;//найдем норму за 26 рабочих дней

S:= (a1+a26)*26/2;//сумма 26-сти членов арифметической прогрессии, все изделия за 26 дней

//вывод на экран промежуточных вычислений не обязателен

writeln ('норма за один день = ',norm1);

writeln ('изделий в 26-й день = ',a26);

writeln ('норма за 26 дней = ',norm26);

writeln ('всего изделий за 26 дней = ',S);

if S >= norm26 then

writeln ('бригада выполнит месячную норму')

else

writeln ('бригада не выполнит месячную норму');

end.

//В вашем условии m - это норма за месяц, т.е. за 26 рабочих дней

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?