В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mihasemi
mihasemi
13.06.2021 23:53 •  Информатика

1.составить программу максимума из двух чисел. 2.составить программу вычисления наибольшего из четырех чисел с использованием процедуры определения наибольшего из двух чисел.

Ответ:
Алёна280104
Алёна280104
30.07.2020 18:26
1) program p1;
var a,b:integer;
begin
writeln('Введите 1-е число: ');read(a);
writeln('Введите 2-е число: ');read(b);
if(a>=b) then writeln('максимальное число: ', a) else  writeln('максимальное число: ', b);
end.

2)
program p1;
procedure MaxNumber(a,b: integer; var max: integer);
begin
   if a>=b then max:=a else max:=b;
end;
var a,b,c,d,m:integer;
begin
writeln('Введите 1-е число: ');read(a);
writeln('Введите 2-е число: ');read(b);
writeln('Введите 3-е число: ');read(c);
writeln('Введите 4-е число: ');read(d);
MaxNumber(a,b,m);
MaxNumber(m,c,m);
MaxNumber(m,d,m);
writeln('максимальное число: ',m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?