В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
znani5
znani5
01.05.2021 21:41 •  Информатика

Составьте программу , которая определяет, количество цифр 2 у числа, введенного с клавиатуры, через я не могу составить именно тело цикла. вот что есть program z_15; var num, f, f2 : longint; var kn2 : byte; begin f: =0; kn2: =0; writeln('enter number'); writeln('p.s. number > zero'); readln(num); while num> 0 do begin if f = 2 then kn2: =kn2 + 1; end; writeln('kn2 is =',kn2); end.

Ответ:
DarkOP
DarkOP
02.10.2020 21:49
Program Z_15;
VAR Num, F, F2 : longint;
var kn2 :byte;

begin
F:=0;
kN2:=0;
writeln('Enter Number');
writeln('P.S. Number > Zero');
readln(NUM);
While Num>0 do
begin
F:=num mod 10;
num:=num div 10;
if F = 2 then
KN2:=KN2 + 1;
end;
Writeln('KN2 is =',KN2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?