В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bbayy
bbayy
09.01.2023 22:59 •  Информатика

Pascalabc. дан одномерный массив целых чисел от -20 до 30 из 15 элементов задан через генератор случайных чисел. составить программу подсчета чисел элементов массива больших его пятого элемента.

Ответ:
Лера22062004
Лера22062004
30.07.2020 06:27
//PascalABC.Net 3.0, сборка 1053
const
  n=15;
var
  a:array[1..n] of integer;
  i,s:integer;
begin
  Randomize;
  Writeln('Исходный массив');
  for i:=1 to n do begin
    a[i]:=Random(51)-20;
    Write(a[i],' ')
  end;
  Writeln;
  s:=0;
  for i:=1 to n do
    if a[i]>a[5] then s:=s+a[i];
  Writeln('Сумма искомых элементов равна ',s)
end.

Тестовое решение:
Исходный массив
-10 0 -10 -13 11 7 13 7 -2 -11 12 19 -20 10 -3
Сумма искомых элементов равна 44
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?