В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bobbygrenn
bobbygrenn
23.07.2021 20:22 •  Информатика

Составьте программу,которая формирует массив из 15 случайных целых цифр от -20 до 20 и чётные цифры делит на 2,а нечётные-умножает на 3

Ответ:
сакина12
сакина12
23.05.2020 18:05

На каком языке нужна программа? 
Пример на Paskal: 
program zadacha; 
var massiv: array [1..15] of integer; i:byte; massiv2:array [1..15] of real; 
begin 
randomize; 
write('Isxodnij massiv: '); 
for i:=1 to 15 do 
begin 
massiv:=random(41)-20; 
write(massiv,' '); 
end; 
writeln; 
writeln('Massiv posle preobrazovanij: '); 

for i:=1 to 15 do 
begin 
if massiv=0 then massiv2:=massiv 
else 
if massiv mod 5 = 0 then massiv2:=massiv*2 
else begin 
massiv2:=massiv; 
massiv2:=massiv2/2; 
end; 
write(massiv2:0:1,' '); 
end; 
readln; 
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?