В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MrHard1
MrHard1
19.02.2023 08:44 •  Информатика

Напишите программу в турбо паскале введите с клавиатуры переменные c и d. если 0

Ответ:
Айхан11111111
Айхан11111111
29.07.2020 18:40
Uses Graph; { Подключаем модуль }
var
  c,d,Gd,Gm:integer;
  k:real;
begin
  Writeln('10<=c<=460; 10<=d<=230');
  Write('Задайте c в пределах от 10 до 460: ');Read(c);
  if (c<10) or (c>460) then Writeln('Неверное значение!')
  else begin
    Write('Задайте d в пределах от 10 до 230: '); Readln(d);
    if (d<10) or (d>230) then Writeln('Неверное значение!')
    else begin
      Gd := Detect;
      InitGraph(Gd, Gm, 'Y:\tp7\bgi'); { Инициализируем графический режим }
      SetColor(4);
      k:=GetMaxX/GetMaxY; { Коэффициент искажений по осям }
      if c<d then Rectangle(Trunc(10/k),10,Trunc((2*d+10)/k),2*d+10)
      else Line(Trunc(c/k),c,Trunc(d/k),d);
      Readln;
      CloseGraph
    end
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?