В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vita1968
Vita1968
05.01.2022 01:00 •  Информатика

80 ! ! нужно составить программу которая проверяла является ли простым числом,введенное с клавиатуры числом

Ответ:
Deelay
Deelay
29.07.2020 16:47
Program zhn;
var
  n,i,sum:integer;
begin
  write('Введите значение: ');
  readln(n);
  for i:=1 to n do begin
    if n mod i = 0 then sum:=sum+1;
  end;
  if sum = 2 then writeln('Число ',n,' является простым.')
  else writeln('Число ',n,' НЕ является простым.');
 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?