Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ЛёхаТихонов
24.10.2020 05:38 •
Информатика
составить программу, которая вводит с клавиатуры любое число от 150 до 255, и выводит символ, соответствующий этому коду.
Ответ:
IncolaRO
29.07.2020 15:24
Формула для рандома:
<переменная> := Random(b-a+1)+a,
где:
a - начальное значение диапазона;
b - конечное значение диапазона.
chr - возвращает символ с определённым номером.
var
x: byte;
begin
randomize;
x:=random(255-150+1)+150;
writeln('Число: ', x);
writeln('Символ: ', chr(x));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Aluniy
18.07.2022 19:24
Компьютерлік ойынға құрылатын құжаттама дегеніміз не...
ДаниилВолоснов
08.04.2023 14:51
Все любят путешествовать, и вы, возможно, тоже. Представьте такую ситуацию. Вы фотографируете и снимаете видеоролики на ваш смартфон. Но внезапно, ваше устройство вам сообщает,...
valyakravets
18.11.2020 21:18
Дан одномерный массив. Запиши верный ответ.−20 36 0 −2 5 14Значение элемента массива — 14.Индекс элемента массива —...
бростас
14.02.2020 08:14
1.Создать текстовый файл input1.txt, содержащий только целые числа (в каждой строке может быть несколько чисел, которые разделяются пробелом). Вывести на экран все числа...
nnn0212
01.06.2020 04:28
Приведены за к поисковому серверу. Расположите обозначения в порядке возрастания количества страниц, которые найдёт поисковой сервер по каждому за Для обозначения логической...
kirillkleptzov
06.09.2022 15:02
1. Почему дисковые носители информации нуждаются в постоянном уходе?2. Укажите возможные нарушения в системе хранения информации на дисках,3. Как определить объем свободного...
olgastavovaya1
07.10.2021 23:35
7КЛАСС В какой клетке окажется Робот после выполнения следующей программы? использовать Робот алг задача нач нц пока клетка закрашена вправо вправо кц нц пока клетка чистая...
Gelia1111
24.09.2020 21:49
Продумайте и изобразите в виде схемы (графа) структуру одного из следующих сайтов: ⦁ «Моя семья» ⦁ «Мой класс» Нарисуйте цветной эскиз оформления главной страницы. Пример...
Какфундик
13.08.2022 13:18
Определите значение переменной х после выполнения следующего фрагмента программы: x := 1; y := 2; z := 3; x := z + y; if z y then x := x – 1 else x := x + 1;...
didlerty
08.02.2022 03:29
Какие анегдоты в сталкере зов припяти!?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
<переменная> := Random(b-a+1)+a,
где:
a - начальное значение диапазона;
b - конечное значение диапазона.
chr - возвращает символ с определённым номером.
var
x: byte;
begin
randomize;
x:=random(255-150+1)+150;
writeln('Число: ', x);
writeln('Символ: ', chr(x));
end.