Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
MrTraserS
22.05.2021 04:24 •
Информатика
Даны действительные числа a,b,c. составьте программу для вычесления max (a+b,c)-min (a+c,b).
Ответ:
plalallalalalal
02.10.2020 21:00
// PascalABC.Net
function max(a,b:real):real;
begin
if a>b then max:=a else max:=b
end;
function min(a,b:real):real;
begin
if a<b then min:=a else min:=b
end;
var
a,b,c:real;
begin
Write('Введите три числа через пробел: '); Read(a,b,c);
Writeln('Результат: ',max(a+b,c)-min(a+c,b))
end.
Тестовое решение:
Введите три числа через пробел: 5 -2 3.8
Результат: 5.8
0,0
(0 оценок)
Популярные вопросы: Информатика
ВІДМІННИК11
27.08.2021 13:48
Як можна прискорити процес форматування тексту, у якому часто трапляються фрагменти з однаковим форматом? За до зміни шрифту Відсутня правильна відповідь За до виділення...
Miss4455
23.11.2022 04:30
Решите задачи: 1) оцените, сколько школьных сочинений размером в 2 машинописные страницы (в одной странице 40 строк по 50 символов в одной строке) можно уместить...
мака2007
09.12.2020 13:30
1. а) 76710; б) 667,12510. 2. а) 1001111001,12; б) 1071,548; в) 18B,0C16. 3. а) 10000111112 + 1111002; б) 111111100,12 + 1011100100,12; 4. а) 11010001002 – 1010101012;...
масякауе
01.01.2022 16:51
сделайте С РЕШЕНИЕМ № 1.1 ; 2.5; 3.2. № 1.9 ; 2.6; 3.3....
Vovannik
08.07.2021 03:20
1.Какие операторы применяются для построения сложного запроса, состоящего из нескольких слов? 2. В каком случае необходимо использовать расширенный поиск?...
Яяяячканр345
04.02.2021 11:51
Массив из 15 элементов заполнить случайными целыми числами от 0 до 35 и вывести на экран в обратном порядке. Программа: PascalABC...
uciviyciy
25.01.2020 21:10
A=775 b=68 x : = a; y : = div(x,100); x : = mod(x, 10) * b x : = x + y...
Ршмшрмпширщ
15.02.2020 17:17
Измените число Y добавив в конец числа две единицы ( 11 ). Сложите полученные числа в модифицированном обратном и модифицированном дополнительном кодах. Результат...
savaam1
05.11.2022 02:06
Подготовьте сообщение зачем нужна красная строка...
АшадЕфремова
26.10.2020 21:42
Расшифруйте ребус. Какой кодирования информации здесь использован?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
function max(a,b:real):real;
begin
if a>b then max:=a else max:=b
end;
function min(a,b:real):real;
begin
if a<b then min:=a else min:=b
end;
var
a,b,c:real;
begin
Write('Введите три числа через пробел: '); Read(a,b,c);
Writeln('Результат: ',max(a+b,c)-min(a+c,b))
end.
Тестовое решение:
Введите три числа через пробел: 5 -2 3.8
Результат: 5.8