В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Abdulla2009
Abdulla2009
01.05.2020 17:30 •  Информатика

Решить на paskal. чтобы открыть секретный сейф, агент 007 решил набирать в возрастающем порядке все трехзначные числа, в записи которых нет одинаковых цифр. составить программу, которая бы печатала все такие числа. определить, сколько времени потребуется ему в худшем случае для вскрытия сейфа, если для набора одного числа он тратит 2с?

Ответ:
Program test ;
Var
a:integer;
Begin
For i:=0 to 9 do begin
For i1:=0 to 9 do begin
For i2:=0 to 9 do begin
If (i<>i1) and (i1<>i2) and (i<>i2) then begin
writeln(" Комбинация введенная агентом 007 - ",i*100+i1*10+i2);
a:=a+2;
End;
End;
End;
Writeln(" В ХУДШЕМ случае он затратит на подбор пароля. ", a div 60,"мин. ",a mod 60,"сек. ") ;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?