Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
irenatum
19.06.2021 09:11 •
Информатика
Дан массив.увеличить каждый положительный элемент вдвое и подсчитать их сумму
Ответ:
01041
28.07.2020 15:19
Const n=10;
var a:array[1..n] of integer;
s,i:integer;
begin
writeln('vvedite massiv=');
for i := 1 to n do
readln(a[i]);
s:=0;
p:=1;
for i := 1 to n do
if a[i]>0 then begin
s:=s+a[i];
a[i]:=a[i]*2;
end;
writeln('s=',s);
readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Лейла1994
26.02.2023 17:13
Якого типу інформаційних систем не існує? 1) локальні ІС 2) глобальні ІС 3) файл-серверні 4) клієнт-серверні...
Master2111
26.01.2021 15:28
Есть 3 шкатулки.в них лежат по 2 драгоценных камня. в одной -2 алмаза , в другой - 2 рубина, в третьей - 1 алмаз и 1 рубин. на шкатулках надписи, но ни одна из них не соответствует...
ProPython
02.10.2020 02:54
Создать текстовый документ с паскаля, в котором n строк и m символов в строке, и символы-цифры 1,...
самира223
10.04.2020 18:26
В7 классе 50 учеников. все они на выходных посетили театр и кино, из них 40 человек ходили в кино, а 35 в театр. сколько учеников ходило только в театр. в ответе укажите только число,...
EzVikaEz
10.04.2020 18:26
найти самую короткую строку в файле и вывести её на экран. если таких строк несколько, то последнюю из них....
EnderCrash7821
30.06.2021 11:02
Какие возможны операции над файлами?...
Кристина6965
30.06.2021 11:02
Вкаких случаях целесообразно проводить архивирование файлов?...
sdfxcg
05.11.2022 21:29
Составить план для презентации на тему франция...
Ушастый1209
05.11.2022 21:29
Каковы функции операционной системы...
lizakonnova
05.11.2022 21:29
Вралли участвуют машины ferrari, toyota и ford. определить, какая машина получит главный приз, если дистанцию за время t1 час, toyota - за t2 час, а ford - t3 час.(считать t1 t2 t3)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a:array[1..n] of integer;
s,i:integer;
begin
writeln('vvedite massiv=');
for i := 1 to n do
readln(a[i]);
s:=0;
p:=1;
for i := 1 to n do
if a[i]>0 then begin
s:=s+a[i];
a[i]:=a[i]*2;
end;
writeln('s=',s);
readln;
end.