В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mement0m0ri
mement0m0ri
08.08.2022 13:43 •  Информатика

Написать программу,которая вводит массив из n целых чисел и выводит на экран элементы с чётными номерами. протестировать программу на произвольных массивах размерностью 5 и 8 элементов.

Ответ:
annykolis
annykolis
07.06.2020 03:55

"Написать программу,которая вводит массив из N целых чисел и выводит на экран элементы с чётными индексами(индексация начинается с нуля). Протестировать программу на произвольных массивах размерностью 5 и 8 элементов."

 

Для программы с 8-ми элементным массивом нужно const int n = 5 изменить на const int n = 8

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
    const int n = 5;
    int a[n];

    cout << "Enter 5 numbers: ";

    for(int i = 0; i < n; i++)
    {
        cin >> a[i];
    }

    for(int i = 0; i < n; i++)
    {
        if(i % 2 == 0)
        {
            cout << a[i] << ' ';
        }
    }
    cout << endl;

   return 0;
}


Написать программу,которая вводит массив из n целых чисел и выводит на экран элементы с чётными номе
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?