В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
2006zahar2006
2006zahar2006
22.11.2022 05:27 •  Информатика

1)вычислить сумму цифр натурального числа z, заданного пользователем. (pascal ) 2)создать приложение в delphi, которое выводит двумерный массив случайных чисел в объекте stringgrid , ввести элементы с клавиатуры и посчитать сумму элементов. 3)составить программу табулирования функции y = sin 2x + cos 3x на отрезке [-1,1] с шагом 0,2. ( pascal ) 4)записать в файл последовательного доступа n действительных чисел. вычислить количество компонентов файла кратных трем и вывести на печать. ( pascal ) 5)на языке delphi создать проект «поиск максимального элемента в числовом массиве», массив заполнить случайными числами и предусмотреть возможность просмотра элементов массива в текстовом поле. 6)создать программу, выполняющую следующие действия. после запуска программы пользователь вводит свое имя, например, александр. появляется вопрос: "александр, ты любишь читать? ". если пользователь нажмет на клавишу да, то должна появиться реплика: "молодец! ", если он нажмет на клавишу нет, то появится реплика: "почему же? надо читать". (delphi)

Ответ:
IDebil
IDebil
28.07.2020 11:29
1)
var a, z, s: integer;
begin 
    write('Введите число: '); 
    read(z); 
    a := z; 
    while a > 0 do 
    begin   
        s := s + a mod 10;   
        a := a div 10 
    end; 
    write('Сумма цифр числа ', z, ' = ', s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?