В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rusakovwn
rusakovwn
07.04.2022 12:03 •  Информатика

Написать программу для подсчета количества счастливых билетов выданных и оставшихся если ваш билет под № n

Ответ:
function isLucky(a: integer): boolean;
var s: string;
begin  
    str(a, s);  
    while length(s) < 6 do s := '0' + s;  
    isLucky := ord(s[1]) + ord(s[2]) + ord(s[3]) = ord(s[4]) + ord(s[5]) + ord(s[6])
end;
var 
    sTicket: string;    
    iTicket, i, err, sum: longint;
begin  
    write('Введите Ваш номер билета: ');  
    read(sTicket);  
    val(sTicket, iTicket, err);  
    for i := 1 to iTicket do    
        if isLucky(i) then inc(sum);  
    writeln('Выдано ', sum, ' счастливых билетов');  
    writeln('Осталось выдать ', 55251 - sum, ' счастливых билетов')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?