В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Lena5737488
Lena5737488
31.03.2023 23:55 •  Информатика

1.составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2.составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.

Ответ:
kulakov2003
kulakov2003
28.07.2020 11:23
1)
var a: integer;
begin
    write('Введите число: ');
    read(a);
    if (a div 10 + a mod 10 + a div 10 mod 10) mod 2 = 0
    then writeln('Сумма цифр четна')                      
    else writeln('Сумма цифр нечетна')
end.
2)
var a: integer;
begin
    write('Введите число: ');
    read(a);
    if a mod 2 = 0 then writeln('Последняя цифра числа четная')
                           else writeln('Последняя цифра числа нечетная')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?