В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
molotok1515
molotok1515
12.02.2023 05:42 •  Информатика

Составьте программу, которая формирует массив из 20 случайных целых чисел, каждое из которых находится в диапазоне от -15 до 15, и выводит на экран вначале исходные, а затем только отрицацельные элементы массива

Ответ:
Ivan21101
Ivan21101
26.05.2020 11:46

program z1;

var

     a:array [1..20] of integer;

     i:integer;

begin

for i:= 1 to 20 do

a[i]:=random(30)-15;

for i:= 1 to 20 do

write(a[i]);

writeln; 

 for i:= 1 to 20 do

if a[i]<0

then  write(a[i]);

end.

 

 

 вроде всё правильно, но желательно всё проверить на программе(у меня удалилась), и ОСОБЕННО проверить строку 7(там в скобках точно не знаю там 30 или 31 должно быть)

 

 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?