В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zaebalovsenasvete
zaebalovsenasvete
24.05.2022 05:46 •  Информатика

Пусть дано некоторое целое число. требуется составить программу, которая выводит на экран монитора сообщение о том, какое это число: положительное либо отрицательное. и если это число положительное, уменьшает его в 2 раза, в противном случае возводит его в квадрат.

Ответ:
Aleksey4569
Aleksey4569
28.07.2020 10:57
Program a2;
var a,b:integer;
begin
 write('Введите целое числo');
 readln(a);
  if a > 0 then  begin
 b:=a div 2;                                   
  end
  else
 begin b:=a*a;
                 end;
  write ('b',b);
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?