В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
volkAlina234
volkAlina234
13.01.2022 16:23 •  Информатика

Дан массив, состоящий из целых чисел. напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного. входные данные сначала задано число n — количество элементов в массиве (1n100). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести количество элементов массива, у которых два соседа и которые при этом строго больше обоих своих соседей. примеры входные данные 5 1 2 3 4 5 выходные данные 0 входные данные 5 1 5 1 5 1 выходные данные 2

Ответ:
Nialya2727
Nialya2727
27.07.2020 23:22
Var
A:array[1..100]of integer;
N,S:byte;
Begin
Read(N);
For N:= 1 to N do
 Read(A[N]);
For N:= 2 to N-1 do
 if (A[N]>A[N-1])and(A[N]>A[N+1]) then S:=S+1;
Write(S)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?