В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
krasotkak31
krasotkak31
31.05.2020 17:16 •  Информатика

Написать программу , которая вычислит отдельные суммы четных и нечетных чисел натурального ряда и их произведения

Ответ:
sosochek47
sosochek47
27.07.2020 22:32
Const
N = 7;
Var
A:array[1..N]of integer;
i:integer;
S,Sn,P,Pn:real;
Begin
S:=0;
Sn:=0;
P:=1;
Pn:=1;
For i:= 1 to N do
Begin
A[i]:=random(7)+1;
Write(A[i],' ');
if A[i] mod 2 = 0 then
Begin
S:=S+A[i];
P:=P*A[i];
End
else
Begin
Sn:=Sn+A[i];
Pn:=Pn*A[i];
End
End;
WriteLn;
WriteLn('Сумма чётных элементов =',S);
WriteLn('Произведение чётных элементов =',P);
WriteLn('Сумма НЕчётных элементов =',Sn);
WriteLn('Произведение НЕчётных элементов =',Pn);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?