В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
korobkovaangelina
korobkovaangelina
06.04.2023 01:55 •  Информатика

Написать программу на языке си для вычисления значений следующих выражений: a=5, c=5 a=a+b-2 c=c+1, d=c-a+d a=a*c, c=c-1 a=a/10, c=c/2, b=b-1, d=d*(c+b+a) выражения, записанные в одной строке, записывать одним оператором-выражением. переменные c и d объявить как целые, переменные a и b – как вещественные. значения переменных b и d вводить с клавиатуры. после вычисления каждого выражения выводить на экран значения всех переменных.

Ответ:
abereziuk2017
abereziuk2017
27.07.2020 21:35
Я конечно не особо программист, но это вроде работает
#include <stdio.h>
int main(){
 float a=5,c=5;
 int b,d;
 printf("Здравствуйте!Введите 2 числа:\n");
 scanf("%d",&b); scanf("%d",&d);
 a += b-2;
 d += c-a-1;
 a = a*c-1;
 a = a/10;
 c = c/2;
 b--;
d = d*(c+b+a);
 printf("В итоге получилось:%F,%F,%d,%d",&a,&b,&c,&d);
 return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?