В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zhigalkinden
zhigalkinden
09.11.2020 10:18 •  Информатика

Нужно решить на python напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 20. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, делящееся нацело на 20. количество чисел не превышает 1000. введенные числа не превышают 30 000. программа должна вывести одно целое число - минимальное число делящееся нацело на 20. входные данные 3 40 240 450 выходные данные 40

Ответ:

n=int(input())

min_na20=30000

for i in range(n):

 x=int(input())

 if x<min_na20 and x%20==0:

   min_na20=x

print(min_na20)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?