Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
sofisofiyaSofi
31.12.2022 06:03 •
Информатика
Паскаль. решить через while. найти все двузначные числа, которые делятся на n и содержат в себе цифру n
Ответ:
Пазновайка
27.07.2020 17:18
Var
A,N,C:byte;
B:boolean;
Begin
B:=false;
Write('N = ');ReadLn(N);
A:=10;
While A<100 do
Begin
if A mod N = 0 then
Begin
C:=A;
While C<>0 do
Begin
if C mod 10 = N then B:=true;
C:=C div 10
End;
if B then Write(A,' ');
B:=false
End;
A:=A+1
End
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
6aPaLlJek
13.01.2020 22:21
Можно ли в python 3.8 сделать цикл в цикле, используя if ? Если нет, то возможно ли его сделать при других операторах? Если да, то почему тут ошибка? val = int(input(...
Karaokpiao
07.12.2020 21:41
Сколько памяти в байтах занимает изображение размером 4 дюйма*5 дюймов, если разрешение изображения 200*200dpi, а каждый пиксель кодируется тремя битами?...
rfrfirb2016oy0uz3
04.03.2022 10:03
Принципы построения и обобщенная структурная схема эвм...
настя7387
04.03.2022 10:03
1. переведите в 2,8,16 системы счисления числа : 552 и 300 в десятой степени. 2.переведите в 8 и 16 системы счисления числа 1111110111101 во второй степени и 1010101010100000...
Хорошист992017
12.03.2022 16:57
Написать программу: программа запрашивает с клавиатуры величину угла. он должен лежать в диапазоне от 0 до 360° [0; 360]. если угол не попадает в диапазон, программа...
Dashuli4ka2001
19.04.2023 18:22
50 б составить блок схему алгоритма и программу для перевода рублей в доллары по курсу, перевода рублей в фунты по курсу, перевода рублей в гривны по курсу, перевода...
Fobsliza
09.04.2020 16:08
Яке місто було центром розвитку романтизму в Західній Україні Івано-ФранківськТернопільЛьвівКраків!ДО ТЬ!...
kutcaki
30.12.2021 03:28
Раскройте скобки, употребив глагол в нужной форме...
CaMo3BaH4uK
17.11.2021 16:23
ответить на вопросы: Какова причина «боксерского восстания»? Против кого выступали?Итоги восстания? ...
Obcenceee
29.07.2022 19:29
Вкажіть відносну молекулярну масу кисню: варіанти відповідей 1.32, 2.16, 3.18, 4.29...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
A,N,C:byte;
B:boolean;
Begin
B:=false;
Write('N = ');ReadLn(N);
A:=10;
While A<100 do
Begin
if A mod N = 0 then
Begin
C:=A;
While C<>0 do
Begin
if C mod 10 = N then B:=true;
C:=C div 10
End;
if B then Write(A,' ');
B:=false
End;
A:=A+1
End
End.