В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
prostosadkotik
prostosadkotik
20.09.2022 12:18 •  Информатика

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными (паскаль авс)

Ответ:
Azhar1605
Azhar1605
27.07.2020 16:26
UPD

Var
a,b,s,i:integer;
begin
readln(a,b);
if a <> b then
for i:=1 to abs(b) do s:=s+a
else for I:=1 to abs(b) do s:=s+a;
if (a<0) and (b<0) then s:=abs(s)
else if b<0 then s:=-s;
writeln(s);
end.
0,0(0 оценок)
Ответ:
kek22821
kek22821
27.07.2020 16:26
Var A,B,i,S:integer;
Ch:Char;
Begin
S:=0;
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
if ((A<0)and(B>0))or((A>0)and(B<0)) then Ch:='-';
A:=Abs(A);
B:=Abs(B);
For i:= 1 to A do
 S:=S+B;
WriteLn(Ch,S)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?