В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
User5281
User5281
14.02.2023 02:20 •  Информатика

Составить программу, заполняющую массив десятью случайными числами и выводящую на экран: 1) максимальное значение; 2)минимальное значение; 3)среднее арифметическое значение.

Ответ:
илья1947
илья1947
23.05.2020 17:52

program n1;
  const n=10;
  var
  mas:array[1..n] of integer;
  i:integer;
  max,min,sum:integer;
  ar:real;
  begin
   for i:=1 to n do

begin
  mas[i]:= random (20)-10;
  write(mas[i],' ');
  writeln
 
end;

  max:=1;
   for i:=2 to n do

   if mas[i]>mas[max] then
   max:=i;
   writeln;
   writeln('Максимаьное значение a[',max,']= ',mas[max]);

   
  min:=1;
  for i:=2 to n do
   if mas[i]<mas[min] then
   min:=i;
   writeln;
   writeln(Минимальное значение a[',min,']= ',mas[min]);
   
 for i:=1 to n do
   sum:=sum+mas[i];
    ar:=sum/n;
   writeln;
   writeln('Среднее арифметическое =  ',ar);
   
end.
{Немного нерационально но работает=)}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?