В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MarkohkaMolovko
MarkohkaMolovko
30.06.2021 06:48 •  Информатика

Напишите программу, которая размещает случайным образом две ладьи на шахматной доске и определяет, бьют ли эти ладьи друг друга.

Ответ:
trikozatatjana1
trikozatatjana1
26.05.2020 09:45

Язык СИ:

#include<stdio.h>

#include<stdlib.h>

#include<float.h>

#include<time.h>

int main(){

   

   srand(time(0));

   const long double cbc=64.0L-FLT_EPSILON;

   unsigned short int r1=cbc/RAND_MAX*rand(),

                                  r2=cbc/RAND_MAX*rand();

   

   printf("R1: %c%c\n",65+r1%8,49+r1/8);

   printf("R2: %c%c\n",65+r2%8,49+r2/8);

   printf("%s\n",r1%8==r2%8 || r1/8==r2/8?"yes":"no");

   

   return 0;

   

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?