В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
darya1122334455667
darya1122334455667
20.04.2020 03:49 •  Информатика

Составьте программу записывающую в файл одномерный массив случайных чисел, а затем считывающую его с диска и выполняющую запись четных элементов в другой файл (на паскале)

Ответ:
888Blond
888Blond
27.07.2020 12:26
Program untitled;
var t,t2:text;
    i,a:integer;
    m:array [1..50] of integer;
begin
randomize;
assign(t,'output.txt');
assign(t2,'output2.txt');
rewrite(t);
 for i:=1 to 50 do begin
 m[i]:=random(50);
 writeln(t,m[i]);
end;
 reset(t);
rewrite(t2);
for i:=1 to 50 do begin
 readln(t,a);
 if a mod 2=0 then
  writeln(t2,a);
 end;
 close(t);
close(t2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?