В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
FREDYPAW
FREDYPAW
20.12.2020 06:50 •  Информатика

Нужно написать программу, до 7 часов утра в paskale. . №1 написать программу, которая с функции удаляет из строки последнее слово. №2 написать программу, которая с функции выводит сообщение true, если цифры в строке расположены по убыванию и false в противоположном случае. если есть вопросы, напишите в коментариях.

Ответ:
Sofochka1309
Sofochka1309
27.07.2020 09:56
//PascalABC.Net
function DelWord(s:string):string;
var
  i,n:integer;
begin
  n:=length(s);
  i:=n;
  repeat
    if i>=1 then Dec(i);
  until s[i]=' ';
  Delete(s,i+1,n-i);
  DelWord:=s
end;

var
  st:string;
begin
  Write('Введите строку: '); Readln(st);
  Writeln('Результат: ',DelWord(st))
end.

Тестовое решение:
Введите строку: А роза упала на лапу Азора
Результат: А роза упала на лапу

//PascalABC.Net
function DescDigits(s:string):boolean;
var
  desc:boolean;
  i,n:integer;
  c1,c2:char;
begin
  n:=length(s);
  desc:=true;
  c1:='A'; { главное, чтобы символ был "старше" любой цифры }
  i:=1;
  repeat
    c2:=s[i];
    if c2 in ['0'..'9'] then
      if c2<c1 then c1:=c2 else desc:=false;
    Inc(i)
  until (i>n) or (not desc);
  DescDigits:=desc
end;

var
  s:string;
begin
  Write('Введите строку: '); Readln(s);
  if DescDigits(s) then Writeln('true') else Writeln('false')
end.

Тестовое решение:
Введите строку: Пример строки с цифрами 98 по убыванию 7 6,5, так4тоже1можно!
true

Вариант первой программы для Borland Pascal 7.01
uses Crt;
function DelWord(s:string):string;
var
  i,n:integer;
begin
  n:=length(s);
  i:=n;
  repeat
    if i>=1 then Dec(i);
  until s[i]=' ';
  Delete(s,i+1,n-i);
  DelWord:=s
end;

var
  st:string;
begin
  ClrScr; 
  Write('Введите строку: '); Readln(st);
  Writeln('Результат: ',DelWord(st));
  ReadKey
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?