В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Abc pascal 1) составьте программу расположения элементов в массиве a(n) в порядке убывания. 2) составьте программу перемены местами в массиве b(n) второго и предпоследнего элементов. 3) составьте программу удаления пятого элемента массива c(n).

Ответ:
Expert228666
Expert228666
02.10.2020 18:53
1)cсортировка методом пузырька 
const n=10;
var    a: array[1..n] of integer;  
  i, j, k: integer; 
begin  
  randomize;   
  write ('Исходный массив: ');  
  for i := 1 to n do begin  
      a[i] := random(256);     
   write (a[i]:4);    end;    
writeln; writeln;    
  for i := 1 to n-1 do   
     for j := 1 to n-i do   
         if a[j] < a[j+1] then begin     
           k := a[j];            
    a[j] := a[j+1];        
        a[j+1] := k        
    end;    
 write ('массив по возрастанию: '); 
   for i := 1 to n do  
     write(а[i]:4);   
  writeln;
 readln;
end.


2)
const    n = 10;
 var    b: array[1..n] of integer; 
   i, j, x: integer; 
begin   
 randomize;  
   write ('Исходный массив: ');  
  for i := 1 to n do begin  
      b[i] := random(256);    
    write (b[i]:4);  
  end;  
  writeln; 
writeln;  
x:=b[2];
b[2]:=b[n-1];
b[n-1]:=x;   
  write ('массив  ');  
  for i := 1 to n do      
  write (b[i]:4);   
  writeln; 
readln
end.


3)
const    n = 10; 
var    c: array[1..n] of integer;  
  i, j, x: integer; 
begin   
 randomize; 
    write ('Исходный массив: ');   
 for i := 1 to n do
 begin     
   c[i] := random(256);     
   write (c[i]:4);   
 end;    
writeln; writeln;  
writeln; 
for i:=5 to n-1 do
c[i]:=c[i+1];

    write ('массив  '); 
   for i := 1 to n-1 do   
     write (c[i]:4);  
   writeln; 
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?