В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
inpurple
inpurple
30.05.2022 09:11 •  Информатика

Составить программу paskal для: 1)найти стороны прямоугольника, у которого известны периметр и площадь 2)дано трехзначное натуральное число. определить, является ли сумма его цифр двузначным числом

Ответ:
Thanks2y
Thanks2y
26.07.2020 20:06
Pascal ABC
1)

Var P,S:real;
Begin
Write('P = ');Read(P);
Write('S = ');Read(S);
if (P/2-sqrt(P*P/4-4*S))/2<0 then S:=(P/2+sqrt(P*P/4-4*S))/2
else S:=(P/2-sqrt(P*P/4-4*S))/2;
WriteLn('Первая сторона равна ',S);
WriteLn('Вторая ',P/2-S);
End.

2)

Var
A:integer;
Begin
Write('A = ');Read(A);
if ((A div 10) mod 10) +(A mod 10)+(A div 100)>9 then Write('Является')
else Write('Не является')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?