В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
юля2720
юля2720
10.07.2020 17:57 •  Информатика

Склавиатуры вводят слово и символ. составьте программу, которая определяет позицию заданного символа.

Ответ:
gadjimira
gadjimira
23.05.2020 17:48

program xxx;

var a,s : string;

   i:integer;

begin

   writeln ('Введите слово и символ-');

   readln (s,a);

   for i:=1 to length(a) do

     if copy (s,i,1)=a then writeln (i);

   readln

end.

 

0,0(0 оценок)
Ответ:
liza08082007
liza08082007
23.05.2020 17:48

паскаль:

 

uses crt;

var a,b:string;\ а-слово ,b-символ

i:integer;\ переменная для счета

begin

writeln ('Слово и символ');

readln (a,b);\\ввод данных

 

for i:=1to length(a) do if copy (a,i,1)=b then writeln (i);\\Копирование по порядку символов слова а  и сравнение каждого с символом b. Вывод ответа. Или ответов 

readkey;\\если символы в слове повторяются

end.

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?