В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
viktoriakeda
viktoriakeda
15.05.2022 10:54 •  Информатика

Составить программу на языке паскаль для вычисления и печати таблицы значений функции y=sin2(x-1)+2cos((x-1)/2), при условии, что x0=0.3, xк=1.7, dx=0.2.

Ответ:
Dashaaleshenko
Dashaaleshenko
26.07.2020 08:59
// PascalABC.Net v2.2 build 1019
program znanija_12709887;

const  
  xMin = 0.3; 
  xMax = 1.7;   
  xStep = 0.2;
var  
  y : real; 
  x : real;
begin 
  x := xMin; 
  while x <= xMax do begin   
    y := sin(2)*(x - 1) + 2 * cos((x - 1) / 2);   
    writeln ('x = ' , x, ' y = ', y);   
    x := x + xStep; 
  end;  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?