Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Xadice12345
28.10.2020 18:31 •
Информатика
Составить программу на языке «рascal» для вычисления значений функции: 3sinx+8, если х
Ответ:
nazirakmtv
26.07.2020 07:20
uses Crt;
const
Pi=3.14159265;
var
x,y:real;
begin
ClrScr;
x:=0;
while x<=Pi do begin
if x<Pi/2 then y:=3*sin(x)+8
else y:=4*cos(2*x);
Writeln('x=',x:8:5,', y=',y:8:5);
x:=x+Pi/10
end;
ReadKey
end.
Тестовое решение:
x= 0.00000, y= 8.00000
x= 0.31416, y= 8.92705
x= 0.62832, y= 9.76336
x= 0.94248, y=10.42705
x= 1.25664, y=10.85317
x= 1.57080, y=-4.00000
x= 1.88496, y=-3.23607
x= 2.19911, y=-1.23607
x= 2.51327, y= 1.23607
x= 2.82743, y= 3.23607
x= 3.14159, y= 4.00000
0,0
(0 оценок)
Популярные вопросы: Информатика
джокер65
30.05.2023 16:42
Дано натуральное число. Напишите программу, которая вычисляет: количество цифр 3 в нем; сколько раз в нем встречается последняя цифра; количество четных цифр; сумму...
найлешка
22.11.2022 00:33
Найти разность двух наименьших из трех чисел c++. завтра зачет и надо сдать будет....
kseniya0090
28.09.2020 09:00
Программа получает на вход последовательность целых чисел, каждое число записано в отдельной строке. Последовательность завершается числом 0, при считывании которого...
1mizik1
08.09.2021 04:19
В две пробирки с раствором хлорида бария (BaCl2) и прилейте: в первую - серной кислоты (H2SO4), во вторую - сульфата калия (K2SO4). Наблюдайте выделение белого...
Богдан2281667
19.05.2020 11:29
4.Read the words and put them in the correct column. Расставь слова в правильные колонки, обращая внимание на добавления окончания. Go, sleep, study, play, catch,...
Шекспир112005
03.11.2020 13:17
Напишите формулы всех оксидов, которые можно составить из записей в приведенных карточках 10 оксидов...
lizochkanaumov1
03.11.2020 13:17
Катер в первый день проплыл 15% всего пути, или 300 км, а во второй 8/25 всего пути. Сколько катер проплыл в третий день???...
Емсимася
13.07.2021 04:58
Распредели предложение смеси...
13kirya13
13.07.2021 04:58
Упрости выражение :-0,25у•8b, 3/7p•7/9q...
liq2354234
13.07.2021 04:58
Дело мастера боится. «Чудесный парикмахер» (по Л. Скребцовой). Урок 1О чём или о ком рассказывается в сказке?О том, как женщины превращались в красавиц.О том, как...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
uses Crt;
const
Pi=3.14159265;
var
x,y:real;
begin
ClrScr;
x:=0;
while x<=Pi do begin
if x<Pi/2 then y:=3*sin(x)+8
else y:=4*cos(2*x);
Writeln('x=',x:8:5,', y=',y:8:5);
x:=x+Pi/10
end;
ReadKey
end.
Тестовое решение:
x= 0.00000, y= 8.00000
x= 0.31416, y= 8.92705
x= 0.62832, y= 9.76336
x= 0.94248, y=10.42705
x= 1.25664, y=10.85317
x= 1.57080, y=-4.00000
x= 1.88496, y=-3.23607
x= 2.19911, y=-1.23607
x= 2.51327, y= 1.23607
x= 2.82743, y= 3.23607
x= 3.14159, y= 4.00000