В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KONERtm
KONERtm
09.11.2022 22:41 •  Информатика

Написать программу в турбо паскале, а именно: протабулировать функцию y=x-пи на отрезке [0; 11] с шагом h=1,1. результаты вычислений вывести на экран в виде таблицы пар чисел x, y. вычислить модуль разности максимального и минимального значений функции y.

Ответ:
Arina200444
Arina200444
02.10.2020 17:45
Uses Crt;
const
  pi=3.14159;
var
  x,y,h,max,min,d:real;
begin
  ClrScr;
  max:=-100; min:=100; x:=0; h:=1.1;
  while x<=11+h/2 do begin
    y:=x-pi;
    Writeln(x:10:7,y:12:7);
    if max<y then max:=y;
    if min>y then min:=y;
    x:=x+h;
  end;
  d:=abs(max-min);
  Writeln(d:10:7);
  ReadKey
end.

Результат выполнения программы:
 0.0000000  -3.1415900
 1.1000000  -2.0415900
 2.2000000  -0.9415900
 3.3000000   0.1584100
 4.4000000   1.2584100
 5.5000000   2.3584100
 6.6000000   3.4584100
 7.7000000   4.5584100
 8.8000000   5.6584100
 9.9000000   6.7584100
11.0000000   7.8584100
11.0000000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?