В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
missliss05
missliss05
04.12.2020 22:48 •  Информатика

Ничего вообще не вообще за модуль,содержащий процедуру..нужно написать программу)если можно с объяснениями) написать модуль,содержащий процедуру нахождения минимальной цифры натурального числа. пример использования данного модуля.(в паскале)

Ответ:
546jbj
546jbj
24.07.2020 22:18
Текст модуля (Free Pascal):
unit MyLib;
interface
  procedure MinDigit(n:longint;var md:byte);
implementation
  procedure MinDigit(n:longint;var md:byte);
  var
    d:byte;
  begin
    md:=10;
    while n>0 do begin
      d:=n mod 10;
      if d<md then md:=d;
      n:=n div 10
    end
  end;
begin
end.

Тестовая программа:
uses
  Crt, MyLib;
var
  p:byte;
begin
  ClrScr;
  MinDigit(45134,p);
  Writeln('p=',p);
  ReadKey
end.

Тестовое решение:
p=1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?