В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aigerim341
aigerim341
16.08.2020 16:10 •  Информатика

Составьте алгоритм и напишите программу для того чтобы выяснить является ли введённое шестизначное число счастливым суперсчастливым или обыкновенным. шестизначное число называют счастливым если сумма первых трёх его цифр равна сумме трёх последних цифр. число будет называться суперсчастливым если оно во-первых счастливое а во-вторых сумма первых трёх его чисел равна 11 или 22

Ответ:
cherrpaha
cherrpaha
24.07.2020 20:56
Var n:longint;
c1,c2:byte;
s:boolean;
begin
s:=false
readln(n);
c1:=(n mod 10)+((n div 10) mod 10)+((n div 100) mod 10);
c2:=((n div 1000) mod 10) + ((n div 10000) mod 10) + ((n div 100000) mod 10);
if c1=c2 then s:=true;
if s and ((c2=11) or (c2=22)) then writeln('supershastlivoe') else
if s then writeln('shaslivoe') else writeln('prostoe');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?