В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
daa86
daa86
26.03.2023 23:07 •  Информатика

Составить программу вычисления в одномерном массиве с произведения четных и положительных элементов и сумму элементов меньших 6

Ответ:
demon959402
demon959402
24.07.2020 20:32
Var
  c:array [1..10] of integer;
  i, even, positive, sumLessSix: integer;
begin
  randomize;
  writeln ('Рандомный массив');
  for i:=1 to 10 do begin
    c[i]:= random(20)-10;
    write (c[i],' ');
  end; {for}
  writeln;
  writeln('Произведение четных чисел');
  even:=1;
  for i:=1 to 10 do
    if c[i] mod 2 = 0  then
    even:= even*c[i];
  write(even,' ');
  writeln;
  writeln('Произведение положительных чисел');
  positive:=1;
  for i:=1 to 10 do
    if c[i] > 0 then
    positive:= positive*c[i];
  write(positive,' ');
    writeln;
  writeln('Сумма элементов меньших 6');
  positive:=1;
  for i:=1 to 10 do
    if c[i] < 6 then
    sumLessSix:= sumLessSix+c[i];
  write(sumLessSix,' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?