В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tk271287
tk271287
11.12.2022 01:55 •  Информатика

(на с++)написать программу. подсчет нулевых элементов в заданном одномерном массиве.

Ответ:
zyzae
zyzae
24.07.2020 19:54
Using namespase std;

void main ()
{
setlocale (LC_ALL, "Russian");
int n, k;\\размер массива и счетчик

cout << "Введите количество элементов массива" << endl;
cin >> n;
float *arr = new float[n]; \\создаем динамический массив, т.к. не знаем сколько дано элементов и какие они

\\заполнение массива с клавиатуры
for (int i=0; i<n; i++)
{
cout << "Введите " << i << "-ый элемент массива" << endl;
cin >> arr[i];
}

\\вывод массива на экран
for (int i=0; i<n; i++) cout << arr[i] << " " ;

\\подсчет нулевых элементов
k=0;
for (int i=0; i<n; i++)
{
if (arr[i] == 0) k++
}

cout << "Количество нулевых элементов в заданном массиве = " << k;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?