Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Elisavettas
23.03.2022 19:39 •
Информатика
Написать программу на пскале для заполнения двумерного массива следующими числами: 2 3 4 5 0 -1 4 5 0 0 -2 -1 0 0 0 -3 0 0 0 0 0 0 0 0 0
Ответ:
MisterStickman1
24.07.2020 19:16
Бред конечно, ну а вдруг так
const
n = 5;
var
a : array[1..n,1..n] of integer;
i,j : integer;
begin
for j := 1 to n-1 do
a[1,j] := j+1;
for i := 2 to n-1 do
a[i,1] := -(i-1);
for j := 2 to 3 do
a[2,j] := a[1,j+1];
a[3,2] := a[3,1]+1;
for i := 1 to n do
begin
for j := 1 to n do
write (a[i,j]);
writeln();
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
kirtema43
03.12.2022 15:05
В соответствие с кодовой таблицей ASCII каждую латинскую букву можно закодировать десятичным числом. Слово file кодируется как 102105108101. Какому слову соответствует...
socnyjarbuz
25.11.2020 18:02
Считая, что каждый символ кодируется в кодировке Unicode, оцените информационный объём следующей фразы: В шести литрах 6000 миллилитров. а) 1024 байта б) 1024 бита...
Karina11111111115
04.06.2020 13:39
Нужен краткий конспект на тему сервисы сети файловые архивы ( )...
Аня20041334
21.10.2022 09:38
1. Какой язык программирования существует: А) Питон Б) Удав B) Анаконда Г) Кобра 2. Выберите команду для вывода данных в Python А) ввод() Б) take() B) input() Г)...
Mozgi1706
09.12.2021 13:01
Написать задачу: Обмен переменных значениями. (Пример: было: а=7, b= 2, стало:а=2, b= 7) Числа вы вводите с клавиатуры...
0101015
29.07.2022 01:33
Пример: причина-следствие например: жара-жажда...
VOLKODAV770
20.10.2020 18:05
Для содержания лошадей был сделан запас сена на некоторое время. Если бы лошадей было на две меньше, то этого запаса сена хватило бы еще на 10 дней; если бы лошадей...
miakakashka
20.10.2020 18:05
Если к числителю некоторой дроби прибавить 3, а знаменатель оставить без изменения, то получится 1; если к знаменателю исходной дроби прибавить 2, не меняя...
kislova04
20.10.2020 18:05
Определить значение Ь, если через точку с координатами (3; 10) проходит график функции, заданной формулой: 1) у=х + b; 2) у = Зх + b; 3) у= -1/3x+b 4) у = -1/2x+b...
tima23qwerty
20.10.2020 18:05
При каких значениях k и b график функции y = kx + b проходит через точки (-1; 1), (2; -3)? 2) Проходит ли график функции у = -2 х-1 через точку (-3; 5)? (-1; 2)?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const
n = 5;
var
a : array[1..n,1..n] of integer;
i,j : integer;
begin
for j := 1 to n-1 do
a[1,j] := j+1;
for i := 2 to n-1 do
a[i,1] := -(i-1);
for j := 2 to 3 do
a[2,j] := a[1,j+1];
a[3,2] := a[3,1]+1;
for i := 1 to n do
begin
for j := 1 to n do
write (a[i,j]);
writeln();
end;
end.