Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Syrup75
02.02.2020 12:58 •
Информатика
Решить в паскале! на шахматной доске стоят черный король и три белые ладьи (ладья бьет по горизонтали и вертикали) . проверить, не находится ли король под боем.
Ответ:
alex07042004
24.07.2020 19:23
const
n = 3; //Кол-во фигур
var
i : integer;
xk,yk : integer;
xl,yl : array [1..n] of integer;
r : boolean;
begin
//Задание координат
//
xk := 2; yk := 2; // Координаты короля
//Координаты ладьи
xl[1] := 1; yl[1] := 2;
xl[2] := 4; yl[2] := 6;
xl[3] := 5; yl[3] := 8;
//
r := false;
i := 1;
While (i <= n) and (not r) do
begin
if (xk = xl[i]) or (yk = yl[i]) then //Лежат на одной прямой
r := true;
i:= i +1;
end;
if r then
writeln ('Король под ударом')
else
writeln ('Король живет)');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Hunnnnty
13.05.2021 12:50
Задание из теста по информатике: соотнесите цвета палитрыCMYK С их названиями на русском языке K,C,M,Y и Чёрный голубой Пурпурный Жёлтый...
AlexGrehova
09.12.2020 03:40
История и перспективы робототехники робот определяет цвета, кроме красного, зеленого и желтогоробот едет вперед и озвучивает цвета светофора, при определении других...
Jessabelle
12.04.2020 20:40
Переведите блок-схему на язык Pascal и результат запишите: Дано основание треугольника и его высота, проведенная к основанию. Найти площадь этого треугольника Начало...
yhjk
24.01.2023 04:02
Информационными моделями являются: информатика словесные описания карты таблицы схемы персональный компьютер...
dadfxhg
13.04.2020 23:44
Программисты на с++ написать код,...
baka8
04.01.2022 19:28
Сформулируйте понятие «компьютерная графика» Какие процессы развитию компьютерной графики как самостоятельной область информатики?Какие изображения называют «цифровыми»?Что...
айдын23
07.11.2021 12:22
қорапта 64 түрлі түсті қалам бар. Қораптан қызыл қалам алынды деген хабар 4 бит ақпарат береді.Қораптпғықызыл қаламдар саны неше?...
Samlina
18.08.2020 02:27
Әлеуметік желі дегеніміз не...
Юлия20122003
11.01.2020 19:09
Ячейки А1:А5 содержат значения 10,7,9,27 и 2 Чему будет равно значение функции?...
Biglok
09.02.2021 14:37
Раскрыть скобки 1)-12(5/6x+1/4y-5/24z-1,1) 2) -(9,4-b)+(-b+3,7)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n = 3; //Кол-во фигур
var
i : integer;
xk,yk : integer;
xl,yl : array [1..n] of integer;
r : boolean;
begin
//Задание координат
//
xk := 2; yk := 2; // Координаты короля
//Координаты ладьи
xl[1] := 1; yl[1] := 2;
xl[2] := 4; yl[2] := 6;
xl[3] := 5; yl[3] := 8;
//
r := false;
i := 1;
While (i <= n) and (not r) do
begin
if (xk = xl[i]) or (yk = yl[i]) then //Лежат на одной прямой
r := true;
i:= i +1;
end;
if r then
writeln ('Король под ударом')
else
writeln ('Король живет)');
end.