В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vania161
Vania161
16.03.2022 07:20 •  Информатика

Нарисовать блок схему и составить программу , которая 1) вводит массив из 10 чисел 2)выбирает в этом массиве числа большие -3.5 и находит из них наименьшее 3) значение наименьшего вывести на печать -100 , -50 , -30 , -3.7 , -3 , 0 , 2 , 3 ,20, 500.

Ответ:
Айнұра
Айнұра
02.10.2020 17:22
Const
  n=10;
var
  a:array[1..n] of real;
  i:integer;
  amin:real;
begin
  Writeln('Введите элементы массива');
  amin:=100;
  for i:=1 to n do
  begin
    Read(a[i]);
    if a[i]>-3.5 then
      if amin>a[i] then amin:=a[i]
  end;
  Writeln('Минимальный среди элементов, больших -3.5: ',amin:0:3)
end.

Тестовое решение:
Введите элементы массива
-100 -50 -30 -3.7 -3 0 2 3 20 500
Минимальный среди элементов, больших -3.5: -3.000

Блок-схема во вложении

Нарисовать блок схему и составить программу , которая 1) вводит массив из 10 чисел 2)выбирает в этом
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?