В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DarknEssDk11
DarknEssDk11
03.03.2023 17:20 •  Информатика

Нарисовать блок схему алгоритма и написать программу,которая: 1)вводит массив а из 10 чисел 2)заполняет два массива в и с длиной 10 первый элемент массива в равен последнему элементу массива а,второй-предпоследнему,и т.д массив с=(а+в)/2 3)вывести в столбец а в с 10 6 8 0 -2 -1

Ответ:
gigeriti28391vlad
gigeriti28391vlad
02.10.2020 17:21
Const
  n=10;
var
  a,b,c:array[1..n] of real;
  i:integer;
begin
  Writeln('Введите элементы массива');
  for i:=1 to n do Read(a[i]);
  Writeln('   A      B      C');
  for i:=1 to n do
  begin
    b[i]:=a[n-i+1]; c[i]:=(a[i]+b[i])/2;
    Writeln(a[i]:7:3,b[i]:7:3,c[i]:7:3)
  end
end.

Тестовое решение:
Введите элементы массива
1.26 -0.3 6.18 7 -7.04 -9.9 -1.7 -2.955 1.75 0.245
   A      B      C
  1.260  0.245  0.753
 -0.300  1.750  0.725
  6.180 -2.955  1.613
  7.000 -1.700  2.650
 -7.040 -9.900 -8.470
 -9.900 -7.040 -8.470
 -1.700  7.000  2.650
 -2.955  6.180  1.613
  1.750 -0.300  0.725
  0.245  1.260  0.753

Блок-схема во вложении

Нарисовать блок схему алгоритма и написать программу,которая: 1)вводит массив а из 10 чисел 2)заполн
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?