Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
littleeeprincess
24.12.2020 23:18 •
Информатика
Составить программу на паскаль: рассчитать радиус окружности, вписанной в треугольник r1= s/p и описанной вокруг треугольника r2= a*b*c/(4*s), где s - площадь, а p - полупериметр треугольника. a, b, c - стороны треугольника ( исходные данные ).
Ответ:
maks110994
02.10.2020 17:20
Находим периметр p=a+b+c, затем полупериметр
, и далее по формуле Герона площадь S.
var
a,b,c,p,s,p2,r1,r2:real;
begin
Write('Введите стороны треугольника: ');
Read(a,b,c);
p:=a+b+c; p2:=p/2;
s:=sqrt(p2*(p2-a)*(p2-b)*(p2-c));
r1:=s/p; r2:=a*b*c/(4*s);
Writeln('R1=',r1,', R2=',r2)
end.
Тестовое решение:
Введите стороны треугольника: 4 6 7
R1=0.704502327470793, R2=3.50685603007684
0,0
(0 оценок)
Популярные вопросы: Информатика
heartanime
26.06.2021 11:09
Решить 2 1)определить является ли введенное с клавиатуры число,положительным.отрицательным,или 0-м. 2)меньше из 2-х заданных чисел заменить числом 10....
kitmyfaded
03.01.2023 03:20
Жесткий диск объёмом 2 гигабайта, полностью занятый информацией, необходимо отформатировать, а информацию временно сохранить на оптических дисках объёмом по 740 мегабайт....
Caxapok24
11.02.2021 14:25
Илья учит английский. Чтобы запоминать слова, он придумал такое правило: повторять и записывать каждое слово столько раз, сколько в этом слове букв. Это правило ему...
999997675656
28.04.2023 14:46
Рассмотрите езду на автомобиле как систему . выделите все кибернетические компоненты в этой системе....
AliAlinka2006
28.04.2023 14:46
1. информационные объем одного символа некоторого сообщения равен 6 битам. сколько символов входит в алфавит, с которого было составлено это сообщение? 2. информационное...
VikaTomaRetaSasha
27.12.2021 06:30
Повесть о том как один мужик двух генералов прокормил. ответьте на вопрос, Какой художественный приём положен в основу произведения рассказа?...
jul45
27.08.2022 23:39
Складіть формулу вуглеводню за назвою: а) 3-етил-2-метилпентан; б) 2-етил-5,6-диметилокт-3-ін ?...
АльбукаеваЗарема
11.02.2022 17:53
1 задание.в групе однокореных слов выдилите корень и расположите слова так чтобы удорение падоло на первый,второй,и т.д слоги слова:молодёж,молод,молоденький дарагой,дорого,дороже,дороговатый...
Анечка12311
10.02.2020 23:18
Вычисли столбиком, выполни проверку: 1930400:3041489600:708можете решить столбиком и отправить фото...
osapkina
10.02.2020 23:18
Сколько стоит такая монета ?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a,b,c,p,s,p2,r1,r2:real;
begin
Write('Введите стороны треугольника: ');
Read(a,b,c);
p:=a+b+c; p2:=p/2;
s:=sqrt(p2*(p2-a)*(p2-b)*(p2-c));
r1:=s/p; r2:=a*b*c/(4*s);
Writeln('R1=',r1,', R2=',r2)
end.
Тестовое решение:
Введите стороны треугольника: 4 6 7
R1=0.704502327470793, R2=3.50685603007684