Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
honutem
14.10.2022 11:10 •
Информатика
По информатике.паскаль люди добрые, решить ,завтра зачёт по информатике,нужно эту решить.вот условие: вывести на экран все трехзначные числа,сумма квадратов цифр которых равна 105. убедительная решить через mod,версия паскаля pascalabc.net
Ответ:
Васиози
02.10.2020 17:13
Var i: integer;
begin
for i:=100 to 999 do
begin
if sqr(i mod 10)+sqr(i div 10 mod 10)+sqr(i div 100)=105
then
writeln(i);
end;
end.
Вывод:
458
485
548
584
845
854
0,0
(0 оценок)
Популярные вопросы: Информатика
rafael700rg
04.07.2021 05:25
Как называется служба поиска и просмотра гипертекстовых документов, включающих в себя графику, звук и видео? WWW Usenet Skype FTP...
Викуля693
14.05.2022 07:43
Помагите Диаграмма қандай элементтерден тұратынын анықта....
ShamilAshimbaj
27.03.2023 18:25
В базе данных хранится информация об учениках класса. Определите поле и вид сортировки, в результате, которой записи будут располагаться в следующем порядке: Абдрахманова, Аутаева,...
tanyaraeva2017
15.04.2021 20:55
Определите к какой группе относятся следующие свойства...
anarrzayev93p09qob
07.02.2020 04:27
Рассчитать формулы по информатике excel ...
Raz1elGG
20.06.2021 16:15
На очередном этапе автогонок «формула-1» первые четыре места заняли шумахер, алези, хилл и кулхардт. опоздавший к месту награждения телерепортер успел заснять пилотов, занявших второе...
dasa2208
20.06.2021 16:15
Программа используется для сокращения объема хранимой или передаваемой информации....
treetmeh
09.03.2020 17:19
Вычислите значение функции: 3 у= х-5 и второе: у=2х+4, если х -1 3х²-х+1, если -1≤х≤3 √х+7, если х 3 блок-схема и программа...
dfghngh
23.02.2021 07:00
Сколько кодов можно составить из 3 бит? сколько надо бит, чтобы можно было составить 8 разных кодов?...
Иванчик1111
23.02.2021 07:00
Дана площадь квадрата. составьте программу для его сторон и периметра....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
for i:=100 to 999 do
begin
if sqr(i mod 10)+sqr(i div 10 mod 10)+sqr(i div 100)=105
then
writeln(i);
end;
end.
Вывод:
458
485
548
584
845
854