В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DAmigoX
DAmigoX
26.07.2020 09:12 •  Информатика

Написать программу в pascal. из предложения вывести слова с заданным количеством слогов.

Ответ:
mishankina1985
mishankina1985
24.07.2020 17:53
Количество слогов считаем по количеству гласных букв в слове.

Program pr;
uses crt;

var str,s: string; 
a,i,j,len,k,kslog: byte;      

Begin 
Writeln('Введите предложение'); 
readln(str);   
Writeln('Введите кол-во слогов'); 
readln(k);   
Writeln('Слова с ',k,' слогами:'); 
Writeln;   

len:=length(str); 
a:=0; 
kslog:=0; 

for i:=1 to len do     
            Begin           
                   if (str[i] = ' ')   then         
                        Begin         
                           s:=copy(str,i+1,a);                   
                 
                           for j:=1 to length(s) do           
                           Begin             
                           if s[j] in ['А','О','У','Э','Ы','Я','Ё','Ю','Е','И','а','о','у','э','ы','я','ё','ю','е','и'] then                                                    inc(kslog);           
                           end;                           
                   if (k=kslog) then Writeln(s);               
                   kslog:=0;               
                   a:=0;         
                      end         
                   else  a:=a+1;     
             end;           

Writeln;     
Writeln('Для завершения программы нажмите Enter');     
readln;      
end.      
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?