В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DenisBru4anovvv
DenisBru4anovvv
16.03.2020 12:48 •  Информатика

Составить программу преобразования заданных действительных значений x и y по правилу: если x и y отрицательны, то каждое значение заменить его модулем; если отрицательно только одно из них, то оба значения увеличить в 2 раза; в остальных случаях оба значения заменить квадратным корнем. p.s. делается всё в pascalabc.net

Ответ:
Аурика1303
Аурика1303
24.07.2020 17:56
Var x,y:real; 
      begin 
  writeln('x='); 
        readln(x);
    writeln('y='); 
   readln(y); 
    if (x<0) and (y<0)
 then
writeln (abs(x), ' ',abs(y)); 
      if (x<0) and (y>0) or (x>0) and (y<0)
 then
writeln(2*x,' ', 2*y);

 if (x>0) and (y=0) or (x=0) and (y>0) or (x>0) and (y>0)
then
writeln( sqrt(x),' ',sqrt(y)); 
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?