В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
uncu4ek
uncu4ek
08.03.2022 01:41 •  Информатика

Составить алгоритм и написать программу на языке pascal: алгоритм вычисления значения функции f(n), где n - натуральное число, задан следующими соотношениями: f(n) = f(n-1)+ f(n/2), при n> 1 и n кратно 2 f(n)=f(n-1) + f(n-2) , при n > 1 и n не кратно 2 f(1)=1 чему равно значение функции f(8)?

Ответ:
isaev40daniil14
isaev40daniil14
24.07.2020 17:47
F=\begin {cases} 1, \ n=1 \\ F(n-1)+F(n/2), \ n=2,4,6,... 2k \\ F(n-1)+F(n-2), n=3,5,7... 2k+1 \end {cases}

function F(n:integer):integer;
begin
  if n=1 then F:=1
  else
    if (n mod 2)=0 then F:=F(n-1)+F(n div 2)
    else F:=F(n-1)+F(n-2)
end;

begin
  Writeln('F(8)=',F(8))
end.

Результат выполнения программы:
F(8)=24
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?