В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
catlolhd14
catlolhd14
29.04.2022 11:46 •  Информатика

:дан массив из 10 целых чисел,от -20 до 20 . напишите программу,заменяющую первый отрицательный элемент массива нулем. решить!

Ответ:
2da0s0ha21
2da0s0ha21
02.10.2020 17:05
var a:array [1..10] of integer;
     i,n,b:integer;
Begin
  for i:=1 to 10 do
    read(a[i]);
  for i:=1 to 10 do
  begin
    if b=0 then if a[i]<0 then 
       begin
         a[i]:=0;
         b:=1;
       end;
  end;

  for i:=1 to 10 do
  write(a[i],' ');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?