В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DarkWolf100
DarkWolf100
28.07.2022 20:50 •  Информатика

Нужно написать программу на языке pascal.на вход подается 2 слова.и программа должна вывести буквы которые встречаются только в одном слове,но не в обоих например: есть слова процессор и информация. результат: п е ф м а я с н

Ответ:
Алексей712
Алексей712
24.07.2020 15:31
PascalABC.Net
var
  sc1,sc2:set of char;
  s1,s2:string;
  c:char;
  i:integer;
begin
  Write('Введите первое слово: '); Readln(s1);
  Write('Введите второе слово: '); Readln(s2);
  sc1:=[]; sc2:=[];
  for i:=1 to Length(s1) do Include(sc1,s1[i]);
  for i:=1 to Length(s2) do Include(sc2,s2[i]);
  foreach c in sc1+sc2-(sc1*sc2) do Write(c,' ')
end.

Тестовое решение:
Введите первое слово: процессор
Введите второе слово: информация
п я н м ф а е с и
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?